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1Welcome to 
PREMIER+™ 2 Configure

Use PREMIER+™ 2 Configure to adjust the settings for displaying 
and exporting your embroidery files, and to register your 
PREMIER+™ 2 Embroidery System.

To get started with PREMIER+™ 2 Configure , open it and select the feature 
that you want to adjust.

The PREMIER+™ 2 Configure setup utility allows you to adjust settings for 
displaying and exporting your embroidery files. It also contains system utilities for 
registering your PREMIER+™ 2 Embroidery System. Adjust the settings on each 
tab of PREMIER+™ 2 Configure.

Use Reset All Apps  if you wish to reset the toolbars and control panels exactly 
as they were when the software was installed. All Preferences settings will be 
restored to their initial values. Reset All Apps does not affect the settings in 
PREMIER+™ 2 Configure.

Reference Guide
The Reference Guide shows how to start the app and provides a quick tour of the 
main screen. The Reference Guide is supplied in PDF format , ready for printing, 
and contains full reference information.

Help
The integrated help contains full reference information. Click the Help button . 
Where available, a help topic appears that is relevant to the selected item. 
Alternatively, use the Help menu.

Viewing and Printing PDF Guides
To find all the Reference and Sample Guides for your PREMIER+™ 2 Embroidery 
System, go to Home/Premier+2/Guides, then double-click Reference Guides or 
Sample Guides. Select the desired PDF guide.

Note; To view and print the PDF Guides, you may use Preview which is included in 
your Mac OS®.

Readme
The most up-to-date details about the PREMIER+™ 2 Embroidery System are in 
the Readme.rtf file available when you install your PREMIER+™ 2 Embroidery 
System.
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Internet FAQs
The FAQ option on the Help menu connects to an internet database of frequently 
asked questions about the PREMIER+™ 2 Embroidery System. Search topics 
relating to the app you are using, or search all topics.

Tutorials
Interactive training exercises are available for many of the apps. They provide a 
'show-me' experience that will help you learn how to use key features of the 
software. The tutorials are found in the online Learning Center on the Internet. 
Use the Help menu, or browse to EmbroideryLearningCenter.com.

Sample Files
Samples are included for your use. The sample files are installed to subfolders of 
Home/Premier+2/Samples/ or the folder of your choice.

Note: To navigate to your Home folder, in the Finder click the Home icon on the 
Favorites sidebar. Alternatively, choose Go > Home, or press ⇧⌘H.

Further Information
For general information on installing the PREMIER+™ 2 Embroidery System, refer 
to the PREMIER+™ 2 Embroidery System Getting Started Guide.

About PREMIER+™ 2 Configure
Access via the PREMIER+™ 2 Configure menu. The version number of 
PREMIER+™ 2 Configure is given here. You will need this if you contact technical 
support at any time.

Starting PREMIER+™ 2 Configure

■ Click the PREMIER+™ 2 Configure icon  in the Launchpad.
■ Double-click the PREMIER+™ 2 Configure icon  in the Finder.

Quit PREMIER+™ 2 Configure
■ Choose PREMIER+™ 2 Configure > Quit PREMIER+™ 2 Configure.
■ Use the red close button  at the top left. 
■ Press ⌘Q
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2Utilities

Use the Utilities tab to start the system utilities.

The utilities are:

• Check Installation 
Run a check to ensure that all components of the PREMIER+™ 2 Embroidery 
System or PREMIER+™ 2 Machine Communication are installed correctly. See 
“Check Installation” on page 4.

• Register 
Register immediately so that you may activate your PREMIER+™ 2 Embroidery 
System software. See “Registration and Activation” on page 5.

• Activate 

When you have installed and registered your PREMIER+™ 2 Embroidery 
System, or purchased an upgrade, you must activate the software. See 
“Registration and Activation” on page 5.

• Smart Update 
With the click of a button, you can run the Smart Update utility to see if any new 
fonts, thread ranges or any other updates have been released. See “Updating 
Your Software” on page 7.

• Reset All Apps 

If desired, in any app you may change the toolbar using View > Customize 
Toolbar. Use Reset All Apps in PREMIER+™ 2 Configure if you wish to reset the 
toolbar, window positions and so on, exactly as they were when the software 
was installed. All Preferences settings are restored to their initial values.
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Note: The settings in PREMIER+™ 2 Configure for displaying embroidery files 
are not affected by the Reset All Apps function. See “Reset All Apps” on 
page 7.

• Reset File Association 
Reset the file associations for embroidery files and embroidery design files. See 
“Reset File Associations” on page 9.

Note: This may be required if other embroidery software is installed after the 
PREMIER+™ 2 Embroidery System.

• Backup My Settings 
Use Backup My Settings to save your My Thread databases, including custom 
threads and My Thread Ranges, My Motifs and My Fills. See “Backup My Settings” 
on page 7.

• Restore My Settings 
Use Restore My Settings to restore the My Settings previously saved by Backup 
My Settings. See “Restore My Settings” on page 8.

Check Installation
Use Check Installation  to run a 
check to ensure that all 
components of the PREMIER+™ 2 
Embroidery System or 
PREMIER+™ 2 Machine 
Communication are installed 
correctly.

Check an installation
■ To check an installation of PREMIER+™ 2 Embroidery System, select Premier+ 

Embroidery System, then click the Check button.
■ To check an installation of the complimentary software downloads for 

PREMIER+™ 2 Machine, select Complimentary Machine Support, then click the 
Check button.
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Registration and Activation
You must register and activate your software before you may install the samples, 
and use the PREMIER+™ 2 Embroidery System.

Note: You may register your PREMIER+™ 2 Embroidery System and activate your 
software either using the computer where your software is installed, or at your 
authorized dealer. Simply bring Product Activation Code Card to the store.

Register and Activate
1 Open the USB stick in the Finder , then click Register and Activate to start the 

registration process.
If you installed from a download, click the PREMIER+™ 2 Configure icon in the 
Launchpad  or Finder , click the Utilities tab, and then click Register .

Note: You can start the registration or activation procedure at any time in PREMIER+™ 2 
Configure by selecting Utilities and then clicking Register  or Activate .

2 You are prompted to open your Internet connection if it is not already open, then the 
Welcome page for PREMIER+™ 2 Embroidery System appears.

3 If you have not registered any TruEmbroidery™ Software or PREMIER+™ Embroidery 
System software before, select the option ’I do not have a previous registration’. If you have 
previously registered any TruEmbroidery™ Software, PREMIER+™ Embroidery System or 
6D™ Embroidery System software, enter your e-mail address and password, then click 
Next.
Note: If you registered software from before the 5D™ Embroidery System, then click the 
link to obtain a password. Once you have received the password, enter it to continue the 
registration process.

4 Enter or check your name and e-mail address in the window that appears. Leave the check 
box selected if you would like to receive an E-mail Newsletter for the latest products and 
updates (highly recommended). Check your details. Click Next to continue.
Note: SVP Worldwide will not give or sell your personally identifiable information to any 
third party outside the network of authorized dealers without your consent. For detailed 
information on our privacy policy, visit our website at PremierPlusEmbroidery.com (Privacy 
Policy).

5 Enter your password (or change it if desired) in the window that appears, then click Next.
Note: The password must have a minimum of 6 characters.

6 A confirmation of account message will appear. Click Next.
Note: The first time you register your software, or if you change your e-mail address, you 
will receive an e-mail confirmation.

7 Enter or check your Contact details in the window that appears. Select your country from 
the list provided. If you live in the United States or Canada, select your state or province 
from the list provided. Click Next.

8 Confirm your dealer information or select a new dealer in the window that appears. This 
dealer should be your primary dealer, the one where you wish to do regular business. It is 
recommended, but not required, to select the check box to inform the dealer of your 
contact details. Enter a second dealer if desired, for example one you may use when 
traveling. Click Next to continue.

9 The Product Activation Codes window will appear. Enter the 18-character Product 
Activation Code found on the Product Activation Code Card (or provided by e-mail if you 
purchased online). Click Next.
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10 After a short time (up to a few minutes) the software is automatically activated. Click Next 
and the Smart Update window appears. Select any recommended updates to download, 
then click Next.

11 A summary window will appear. A list of the PREMIER+™ 2 Embroidery System you have 
registered, together with the Product Activation Codes, is provided. If desired, print out the 
summary for your records.
Note: The software has now been activated and you are able to use your PREMIER+™ 2 
Embroidery System, and install the samples.

1 Click the Samples package. 
Note: This package installs the embroidery and design samples.

2 When a message appears about running a program to determine if the software can be 
installed, click Continue. The Samples installer starts.
Note: If you have not activated your software, a further message will appear. Activate your 
software before installing the Samples.

3 When the welcome page appears click Continue, then print or save the Readme, and accept 
the license agreement. Click Install to install the samples, and Close to end the installer.

Add Your PREMIER+™ 2 Embroidery System Apps to the Dock
1 Click the PREMIER+™ 2 Embroidery icon in the Launchpad  or Finder  to start 

PREMIER+™ 2 Embroidery.
2 Control–click the PREMIER+™ 2 Embroidery icon in the 

Dock.
3 Choose Options > Keep in Dock. You can now open 

PREMIER+™ 2 Embroidery at any time from the Dock.
4 Click the PREMIER+™ 2 Thread Cache icon in the 

Launchpad  or Finder  to start PREMIER+™ 2 
Thread Cache.

5 Control–click the PREMIER+™ 2 Thread Cache icon in 
the Dock and choose Options > Keep in Dock.

6 Click the PREMIER+™ 2 Configure icon in the Launchpad  or Finder  to start 
PREMIER+™ 2 Configure, then Control–click the PREMIER+™ 2 Configure icon in the 
Dock and choose Options > Keep in Dock. (If PREMIER+™ 2 EMBROIDERY or 
PREMIER+™ 2 EXTRA are owned, all of your PREMIER+™ 2 Embroidery System apps can 
now be easily accessed from the Dock.)
Note: If you only own PREMIER+™ 2 Machine Communication, open PREMIER+™ 2 
QuickFont in the Launchpad  or Finder , then Control–click the PREMIER+™ 2 
QuickFont icon in the Dock and choose Options > Keep in Dock. (If PREMIER+™ 2 
EMBROIDERY, PREMIER+™ 2 EXTRA or PREMIER+™ 2 ULTRA is owned, use the 
QuickFont Assistant  button in the Letter window.)

7 If PREMIER+™ 2 ULTRA is owned, click the PREMIER+™ 2 Create icon in the 
Launchpad  or Finder  to start PREMIER+™ 2 Create, then Control–click the 
PREMIER+™ 2 Create icon in the Dock and choose Options > Keep in Dock.

8 If PREMIER+™ 2 ULTRA is owned, click the PREMIER+™ 2 Modify icon in the 
Launchpad  or Finder  to start PREMIER+™ 2 Modify, then Control–click the 
PREMIER+™ 2 Modify icon in the Dock and choose Options > Keep in Dock.
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9 If PREMIER+™ 2 ULTRA is owned, click the PREMIER+™ 2 Cross Stitcher icon in the 
Launchpad  or Finder  to start PREMIER+™ 2 Cross Stitcher, then Control–click the 
PREMIER+™ 2 Cross Stitcher icon in the Dock and choose Options > Keep in Dock. (If 
PREMIER+™ 2 ULTRA is owned, all of your PREMIER+™ 2 Embroidery System apps can 
now be easily accessed from the Dock.)

10 In PREMIER+™ 2 Configure, click Check Installation  and select PREMIER+ 2 
Embroidery System. Click the Check button to check the installation. All items should be 
present.

Prepare for Sending to Your Embroidery Machine
11 Open PREMIER+™ 2 Machine from the Launchpad  or the Finder .
12 Connect your embroidery machine. See “Sending Embroideries” on page 18.

Updating Your Software
With the click of a button, you can run the Smart Update  utility to see if any 
new fonts, thread ranges or any other updates have been released. 

1 Close any PREMIER+™ 2 Embroidery System apps that may be open.
2 Open PREMIER+™ 2 Configure from the Launchpad  or Finder .
3 Click Smart Update .
4 You are prompted to open your Internet connection if it is not already open, then the 

Software Registration page for PREMIER+™ 2 Embroidery System appears. Enter your e-
mail address and password to log in. A system check is made automatically.

5 The Smart Update summary window will appear. A list of the recommended updates for 
your PREMIER+™ 2 Embroidery System is provided. (If there are no new updates it is 
stated that no updates were found for your system.)

6 Click the links to the desired updates to download them.
7 Close the Smart Update window and PREMIER+™ 2 Configure. Then follow the on-screen 

instructions to install the updates.
Note: You can only use Smart Update if you have registered your PREMIER+™ 2 Embroidery 
System and can connect to the Internet on the computer where your software is installed. 
Alternatively, check with your local dealer or use the Internet to see which updates are 
available.

Reset All Apps
If desired, in any app you may change the toolbar using View > Customize Toolbar. 
Use Reset All Apps  if you wish to reset the toolbar, window positions and so 
on, exactly as it was when the software was installed. All Preferences settings are 
restored to their initial values.

Note: The settings in PREMIER+™ 2 Configure for displaying embroidery files and 
exporting your embroidery files are not affected by the Reset All Apps function.

Backup My Settings
Use Backup My Settings  to save the following:

• My Thread databases, including custom threads
• My Thread Ranges list
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• My Motifs
• My Fills

You may wish to do this, for example, when you are moving to a new computer.

Backing Up Your Settings
1 Click Backup My Settings  and a Save dialog appears. 
2 In the dialog the default name for the backup file is 'Premier+_MySettings.zip'. If desired, 

change the name. For example, include the backup date in the name.
3 Click Save to save the backup file in the default Home/Premier+2/System Backup folder. 

Alternatively, browse to a different folder to save the backup file. 
A message will appear when the backup has completed successfully.

4 If desired, create a copy of the backup on media such as a USB memory stick or DVD.

Backing Up Fonts and Backgrounds
Note: Do not copy system fonts or backgrounds provided with your PREMIER+™ 
2 Embroidery System as this may affect the Smart Update process.

To backup fonts created with the QuickFont Assistant in PREMIER+™ 2 
Embroidery, copy them from the My Fonts folder.

Backup Your My Fonts Folder
1 Open Finder.
2 In the Go menu, hold down the Option key and choose Library.
3 Choose Application Support/VsmSoftware/Premier+2/Fonts/My Fonts.
4 Copy the My Fonts folder to backup media such as a USB memory stick or DVD.

Backup your Backgrounds
■ To backup backgrounds created with the Background Assistant in PREMIER+™ 2 

Embroidery, copy them from the subfolders of Home/Premier+2/Backgrounds/. 
The main folders for backgrounds you create should be 

• Backgrounds/Garments/My Garments
• Backgrounds/QuiltBlocks/My QuiltBlocks

Restore My Settings
Use Restore My Settings  to restore the My Settings previously saved by Backup 
My Settings.

Restoring Your Settings
1 Click Restore My Settings and an Open dialog appears showing the System Backup folder. 
2 If needed, browse to the location of the My Settings backup file.
3 Click the backup file then click Open. 

A confirmation message appears, indicating that this will overwrite the current My Settings. 
4 Click OK and the My Settings are restored.
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Reset File Associations
Use Reset File Associations  to reset the file associations for embroidery files 
and embroidery design files.

Note: This may be required if other embroidery software is installed after the 
PREMIER+™ 2 Embroidery System.

Resetting File Associations
1 In the Utilities tab of PREMIER+™ 2 Configure, click Reset File Associations .
2 Select (check) the file types that you want to associate with your PREMIER+™ 2 

Embroidery System.
3 Click OK to reset the file associations for those file types.

If you click one of these file types to open it, it should now be opened by your PREMIER+™ 
2 Embroidery System.
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3Appearance Options

Use the Appearance settings to vary the way embroidery files are displayed in your 
PREMIER+™ 2 Embroidery System.

Background Color
Set the background color for PREMIER+™ 2 Embroidery System to whatever you 
prefer. Click the Color block and the Colors window appears to allow you to 
choose a color. The color set by default for your PREMIER+™ 2 Embroidery 
System is 211, 233, 255 (RGB).

Note: When you click on a color, the Background Color will change immediately. 
You will see the effect in any PREMIER+™ 2 Embroidery System apps that are 
open. When you are happy with the color, close PREMIER+™ 2 Configure.

Colored PencilsSelect a color model

Click to select a color

Drag the selected color 
to the palette
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Background Texture
Select the texture that is used in your PREMIER+™ 2 Embroidery System. 

■ Choose the desired fabric type from the pop-up menu, or select None to have no 
texture.

Grid Color
Set the grid color for your PREMIER+™ 2 Embroidery System to whatever you 
prefer. Click the Color block and the Colors window appears to allow you to 
choose a color. The color set by default for your PREMIER+™ 2 Embroidery 
System is 127, 127, 127 (RGB).

Real Size
Use the on-screen ruler to adjust the settings so that your PREMIER+™ 2 
Embroidery System can display embroideries at their real-world size. 

Note: The real size measurement is 100% on the Zoom Slider.

Change the Measurement for Real Size
1 Hold a ruler against the screen and measure the number of millimeters that correspond to 

the length of the on-screen ruler. 
2 Enter this number in the box, or use the arrows to change the number. 

Note: You will see the effect on the Zoom Percentage in any PREMIER+™ 2 Embroidery 
System apps that are open.

3 When you are happy with the measurement, close PREMIER+™ 2 Configure.

Show Measurements In
Choose between Millimeters and Inches for entering and viewing measurements in 
your PREMIER+™ 2 Embroidery System. The alternative units will be shown when 
you hover the pointer over a measurement.

Note: When Inches is selected, the underlying dimensions are still in Millimeters 
and the nearest equivalent Stitch Lengths are shown in inches.

The default measurements for your PREMIER+™ 2 Embroidery System are 
Millimeters.

Cut-out Appliqué Background Color
Set the appliqué background color for PREMIER+™ 2 Embroidery System to 
whatever you prefer. Click the Color block and the Colors window appears to 
allow you to choose a color. The color set by default for your PREMIER+™ 2 
Embroidery System is 128, 128, 128 (RGB).

Texture
Select the texture that is used for cut-out appliqué background fabric in your 
PREMIER+™ 2 Embroidery System. 

■ Choose the desired fabric type from the pop-up menu, or select None to have no 
texture.
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4Import, Export and Connection

Use the Import options to choose a thread range, and the Export 
options to configure the way your embroidery files are saved and 
stitched out. Use the Connection options to manage access to your 
mySewnet™ account.

Import
Use the Import tab to choose a thread range for your PREMIER+™ 2 Embroidery 
System.

Import Thread Range
Select the palette that is active when loading embroidery files in your PREMIER+™ 
2 Embroidery System unless their colors have already been set from another 
Thread Range. Choose from the following Thread Manufacturers: Robison-Anton 
Rayon 40, Anchor-Alcazar Rayon 40, Icord Poly 40, Isafil Rayon 40, Madeira Poly 
Neon 40, Madeira Rayon 40, Robison-Anton Poly 40, Sulky Poly Stickma 40, Sulky 
Rayon 40. 

■ Choose a thread range from the pop-up menu.

Export
Use the Export tab to vary the way embroidery files are saved and stitched out in 
your PREMIER+™ 2 Embroidery System.

Note: Change the file format, if desired, in the Export dialog of each PREMIER+™ 2 
Embroidery System app.

Optimize for Sewing Options
All of these options are initially selected when saving as a combined .vp3 file, or in 
any other format.

Create placement stitches for Decorations,

Rotate the embroidery to fit the hoop 

Settings for splitting with Multipart Hoops
Set the suffix to add to an exported file name

Route split line to minimize cut stitches
Use a straight line
Add an alignment cross at the end of 

Select the Optimize for Sewing settings

or remove decorations

orientation, or flip it for stitching in reverse 

each section
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Note: You can customize the Optimize for Sewing Options when exporting in any 
PREMIER+™ 2 Embroidery System app.

Combine: Merge the embroideries into a single embroidery during Export.

Note: Combine is not enabled if there is only one design, and for embroidery 
formats that are automatically combined.

Remove Overlap: Prevent areas of stitches building up where embroideries 
overlap.

Remove Overlap is not available when Combine is not enabled.

Note: Only deselect this option if, for example, your embroideries are low density 
and you wish to have a blend effect where they overlap.

ColorSort: Reduce the number of thread colors during Export.

Optimize Stitch Length: Automatically remove small and insignificant stitches. 
See “Optimize Stitch Length” on page 16.

Note: Cutwork Needle lines in the Inspira Cutwork Needle "thread range" are 
unaffected by Optimize Stitch Length.

Decoration
Create Center or Line placement stitches for Decorations added in PREMIER+™ 
2 Embroidery Extra, or remove all decorations and their associated placement 
stitches.

Center or Line Placement
Center or Line marker stitches are created automatically for decorations 
according to the options set here. The settings may be altered when you export 
the embroidery.

• Center placement stitches are recommended when most decorations are 
individual and symmetrical. 

• Line placement stitches are recommended when most decorations are individual 
and asymmetrical (such as bugle beads) or lines of closely spaced beads or 
sequins.

Create as Center Markers: Create a small cross shape in stitches to show 
where the decoration is to be placed.

Create Line Markers: Create a single stitch that runs along the length of the 
decoration.

Remove all decorations: Remove all decorations and marker stitches from the 
exported version. This may be desired to create an embroidery with a 
complementary crystal transfer template (made using the Export Decoration 
Template dialog in PREMIER+™ 2 Embroidery). 
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Hoop Orientation
Set the hoop orientation.

Rotate to fit natural hoop position: Rotate the embroidery if needed to fit 
with the default hoop orientation for the machine. This option is only available if 
the hoop on the main screen is in the rotated orientation. It is useful if you prefer 
to create a "landscape" shaped project in the rotated orientation.

Automatically flip if Felting Needle detected: Flip the embroidery for 
stitching in reverse. If an embroidery contains a Felting Needle color effect this 
option is selected initially. 

Export File Name
When a file is exported, a suffix is added to the file name of the exported version 
to distinguish it from the original multipart embroidery file. 

■ Use Export File Name to change the text used for the suffix. The initial text is 
"Exported".

Splitting for Multipart Hoops
Embroideries for Multipart hoops are split automatically, according to your Export 
settings. Use an Intelligent or Straight Line Split.

Note: There is no need to ensure embroideries are in one stitch area of the hoop; 
just place your embroideries in the most pleasing arrangement. 

Split Method
You can use one of two split methods:

• Intelligent Split automatically calculates a split line that cuts the minimum 
number of stitches, and minimizes cuts through solid sections of embroidery. 
Where possible, use Intelligent Split.

• Straight Line Split cuts the embroidery straight across the center line of the 
overlap zone.

Intelligent with Tolerance
Intelligent Split calculates a split line that cuts the minimum number of stitches, and 
minimizes cuts through solid sections of embroidery. For example, a large 
embroidery is split at a narrow section, and an embroidery that fits in one stitch 
area of the hoop is left in one piece even if it is part of a larger design.

Tolerance ensures that the Intelligent Split line stays a short distance from the 
edges of the overlap. This allows for play in the hoop when going from one hoop 
area to another, such as when aligning a hoop that has been turned to stitch out 
the other side of an embroidery.

You can set Tolerance from 0 to 3mm, in steps of 1mm. The initial setting is 1mm.
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Use Intelligent Split with Tolerance
■ Select the "Intelligent with Tolerance" checkbox, then enter a number in the 

Tolerance number box, or use the arrows to increase or decrease the Tolerance.

Straight with Compensation
Straight Line Split cuts straight across the center of the overlap zone. Straight Line 
Split will only split an individual embroidery if, before it is combined with 
everything else, it does not fit entirely into one stitch area of the hoop.

Note: Lettering is split straight down the middle, as with any other type of 
embroidery. This may cut through characters rather than gaps and spaces. In such 
cases, it is recommended to use Intelligent Split instead.

Compensation adds overlapping stitches along the edges where the embroidery 
is split. This compensates for pull on the fabric.

Alignment Stitch for Turnable Hoops
Select this option to add an alignment cross at the end of the first embroidery 
section when using the HUSQVARNA VIKING® Designer Majestic™, PFAFF® 
creative Grand Dream™, Universal Multipart hoop, Brother Jumbo Frame or 
Janome Giga Hoop. A hoop movement to the alignment cross is added at the 
beginning of the next section. The next embroidery section can then be correctly 
aligned, or alignment can be confirmed.

None Use None if you can split an embroidery without cutting through any of the 
design elements. Compensation is initially set to None.

Low Use Low when cutting through a lightly stitched embroidery or when the split 
lines go through only a few stitch areas.

High Use High when the embroidery is dense, when the split lines make long splits 
through stitch areas, or when stitching onto materials such as knitted or 
stretchy fabric.
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Optimize Stitch Length
Use Optimize Stitch Length to automatically remove small and insignificant 
stitches.

Stitch Length Sensitivity
Adjust the sensitivity of the optimization. Low is set as the default.

■ Choose Low, Medium or High from the pop-up menu.

Minimum Significant Stitch Length
Select the shortest stitch length that you consider to be significant. Stitches below 
this length are removed during the optimization process. The default stitch length 
is 0.8 mm.

Note: Cutwork Needle lines are unaffected by the Minimum Significant Stitch 
Length.

Choose 0.6 mm, 0.8 mm or 1.0 mm from the pop-up menu.

Connection
Use the Connection tab to manage the connection between your computer and 
your mySewnet™ account.

mySewnet™
Enter an e-mail address and password to connnect to your mySewnet™ account.

Note: Once signed in, you remain signed in (even between sessions) until you sign 
out.

Adjust the sensitivity
Set your shortest desired stitch length

Enter your email address

Sign out from your mySewnet™ account

Sign in to your mySewnet™ account

Register for a mySewnet™ account
Change the password for your account

Set a Computer Name for your account

Activate your software via a network
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Register if you don’t have a mySewnet™ Account
Use this option to set up a mySewnet™ Account.

Reset your password if you’ve forgotten it
Use this option to reset the password for your mySewnet™ Account.

Computer Name
Set a name for your computer in your mySewnet™ Account. For example, set 
different names for your laptop and desktop computers.

Note: Initially, the name of your computer user account is displayed.

Network Activation
This option is used only when activating a computer over a network using a 
network license, for example in a class room situation.

Note: You cannot activate an individual license using this option. Only use this 
option when told to by an educator in class, or similar.
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5Sending Embroideries

Send designs to and from your mySewnet™ enabled embroidery 
machine, use PREMIER+™ 2 Machine to change your mySewnet™ 
settings, and send embroideries to some HUSQVARNA VIKING® 
and PFAFF® machines using Direct USB Connection.

Send designs to your mySewnet™ enabled embroidery machine via mySewnet™ 
from within the PREMIER+™ 2 Embroidery System, or directly from your 
mySewnet™ account.

Use PREMIER+™ 2 Machine to change your mySewnet™ settings, and to send 
embroideries directly to some HUSQVARNA VIKING® or PFAFF® machines 
using Direct USB Connection.

Sending via mySewnet™
Send to mySewnet™ and Send to Machine via mySewnet™ are available in 
PREMIER+™ 2 Embroidery, PREMIER+™ 2 Modify, PREMIER+™ 2 Cross Stitcher 
and PREMIER+™ 2 Create. 

Sending from a Machine to PREMIER+™ 2 Embroidery
You can send an embroidery from a mySewnet™ enabled embroidery machine to 
PREMIER+™ 2 Embroidery on your computer. Adjust the embroidery, then return 
it to your machine for stitching.

To be able to send from your machine to PREMIER+™ 2 Embroidery, and to send 
to your machine with Send to Machine via mySewnet™:

■ PREMIER+™ 2 Machine must be running on the computer
■ You must use a mySewnet™ enabled embroidery machine with the most recent 

updates installed
■ The computer and embroidery machine must be signed in to the same 

mySewnet™ account.

Note: An embroidery moved from a machine to PREMIER+™ 2 Embroidery will 
include no special features from the embroidery machine, for example changing the 
words for lettering. This is also true of designs sent in the other direction.

Send from an Embroidery Machine
1 Go to the embroidery machine.
2 Tap the Cloud button at the top and ensure that you are signed in to mySewnet™.
3 Select embroidery mode, and then load an embroidery.
4 In the machine screen, choose the send to software option. 
5 Select the computer to send to, then send the embroidery. 

The embroidery will open in a new PREMIER+™ 2 Embroidery window.
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6 When you have adjusted the embroidery, save the changes to your computer.
Note: You can name your computer in the Connection tab of PREMIER+™ 2 Configure. See 
“Connection” on page 16.
You can then use Send to Machine via mySewnet™ to return the edited 
embroidery to your machine for stitching out.

Using Send to Machine via mySewnet™
Send to Machine via mySewnet™ is available in PREMIER+™ 2 Embroidery, 
PREMIER+™ 2 Modify, PREMIER+™ 2 Cross Stitcher and PREMIER+™ 2 Create.

1 Choose File > Send to Machine via mySewnet™.
2 Choose your machine name in the list. 

A message tells you that the design was sent.
3 On the machine, tap to accept the design from your computer.
4 Stitch out the design.

Note: Use Send to mySewnet™ in the Finder to send embroideries to mySewnet™. See 
“Sending via mySewnet™” on page 18.

Sending to a Machine via Direct USB Connection
Use PREMIER+™ 2 Machine to send embroideries directly to your embroidery 
machine screen, or to the embroideries folder on your embroidery machine with 
Direct USB Connection.

■ PREMIER+™ 2 Machine must be open to transfer files directly to and from the 
embroidery machine when it is connected to your computer. 

■ Use the file manager on your embroidery machine to browse your computer and 
copy embroideries to any folder on your machine.

Note: When Direct USB Connection is established, the machine name will be 
shown in the Machine menu.

Using PREMIER+™ 2 Machine with Direct USB Connection
1 First, check your Direct USB connection.

Switch off your embroidery machine.
2 Click the PREMIER+™ 2 Machine icon in the Launchpad  

or Finder .
PREMIER+™ 2 Machine appears as a menu bar icon.

3 Click the PREMIER+™ 2 Machine menu bar icon .
The pop-up menu shows that your embroidery machine is not 
connected via Direct USB.

4 Switch on your embroidery machine, and wait for it to 
initialize.

Your embroidery machine is now listed. You can send embroideries to its screen or designs 
folder.
Note: Communication is also shown as established if a connection exists with mySewnet™.

5 Open PREMIER+™ 2 Embroidery, then use Open to load an embroidery design.
6 Choose File > Send Express (or press ⌥⌘I). The embroidery appears on the embroidery 

machine screen.
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Note: You can now stitch it on your embroidery machine.
7 Choose File > Send (or press ⌥⌘2). The embroidery is copied to the design folder on 

your embroidery machine.
Note: You can also send embroideries to your directly connected machine using the Finder. 
See “Finder Integration & Spotlight” on page 22.

8 Click the PREMIER+™ 2 Machine menu bar icon  to view the menu.
9 Ensure that Start Automatically is selected, to start PREMIER+™ 2 Machine whenever your 

computer is started.
10 Click About PREMIER+™ 2 Machine to view the version number.

Note: You will need this version number if you contact technical support at any time.
11 Click the PREMIER+™ 2 Machine menu bar icon  and choose Quit to close PREMIER+™ 

2 Machine.

PREMIER+™ 2 Machine
Use PREMIER+™ 2 Machine to change your mySewnet™ settings in PREMIER+™ 
2 Configure, and to send embroideries directly to the embroidery machine screen, 
or to the embroideries folder on HUSQVARNA VIKING® or PFAFF® machines 
with Direct USB Connection.

When the PREMIER+™ 2 Machine app is running, there is an icon in the menu bar. 
The icon shows whether there is communication with your machine:

Note: To change your mySewnet™ settings, see “Connection” on page 16.

Use the file manager on your machine to browse your computer and copy 
embroideries to any folder on your machine.

Use the PREMIER+™ 2 Machine menu to check the status of your mySewnet™ or 
Direct USB Connection.

Starting PREMIER+™ 2 Machine

■ Click the PREMIER+™ 2 Machine icon  in the Launchpad.
■ Double-click the PREMIER+™ 2 Machine icon  in the Finder.

Quit PREMIER+™ 2 Machine
When you quit PREMIER+™ 2 Embroidery System the open windows are 
remembered for when the program is next opened.

■ Click the PREMIER+™ 2 Machine icon  on the menu bar, and choose Quit from 
the pop-up menu.

Communication established No communication
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PREMIER+™ 2 Machine Menu
Click the PREMIER+™ 2 Machine icon on the menu bar 
to see a menu of options.

The menu tells you whether you are signed in to 
mySewnet™, and if Direct USB connection is active.

Note: For mySewnet™ the current status in 
PREMIER+™ 2 Configure is listed, for Direct USB your 
machine name or Not Connected are present. If you 
have more than one machine, the first found is used.

■ Choose About PREMIER+™ 2 Machine to see the version number and copyright.
Note: You will need this version number if you contact technical support at any 
time.

■ Select Start Automatically to select or deselect the automatic start when the 
computer starts.

■ Select mySewnet™ Options to view the Connection tab in PREMIER+™ 2 
Configure. See “Connection” on page 16.

■ Select Help to display help pages about PREMIER+™ 2 Machine.
■ Select Exit to close PREMIER+™ 2 Machine and remove it from the system tray.

The mySewnet™ Cloud Sync Tool
Use the mySewnet™ Cloud Sync Tool app to manage the content of your 
mySewnet™ compatible embroidery machine from your Mac.

The mySewnet™ Cloud Sync Tool is available from: www.mysewnet.com

Select your machine brand, Register or Sign In, and in the Home page select 
mySewnet™ Cloud to download and install the Sync Tool.

The Menu Bar Icon
When the mySewnet™ Cloud Sync Tool is running, there is an icon in the menu 
bar. The icon will show whether or not the Sync Tool is running:

■ Click the icon to see the mySewnet™ Cloud Sync Tool menu.

For more information, view the Quick Start guide on the mySewnet™ website.

Sync Tool Active Sync Tool Inactive
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6Finder Integration & Spotlight

Use Finder and Spotlight to view your embroideries and their details.

When PREMIER+™ 2 Embroidery System is installed, it is integrated with the 
Finder so that embroidery files can be viewed as icons, and the Spotlight search 
feature can be used on embroideries, and embroidery details.

• Open embroidery designs in PREMIER+™ 2 Embroidery or PREMIER+™ 2 
Modify.

• Open design outline files (.edo) in PREMIER+™ 2 Create.
• Open cross stitch design files (.krz) in PREMIER+™ 2 Cross Stitcher.

Note: Embroidery design outline (.edo) files appear in the Finder with a colored 
representation of the filled areas.

Note: Melco (.exp) embroidery files cannot be seen in the Finder. Use Insert to 
open them.

View Embroideries in the Finder
1 Click the Finder icon  in the 

Dock to open it.
2 In the Finder, click the Home icon 

on the Favorites sidebar. 
Alternatively, choose Go > Home, 
or press ⇧⌘H.

3 Click Column view  (the third 
button).

4 Browse to Premier+2/Samples/
Studio/Stitch2/Landscapes.

To learn how to Go to

View the details for an embroidery in the Finder. See “View Embroideries in the Finder” 
on page 22.

View the design information in the Quick Look 
window for the file.

See “Quick Look” on page 26.

Search for embroidery designs using Spotlight. See “Searching for Embroideries” on 
page 35.

Create a copy of the selected embroideries in 
another embroidery file format, with a different 
thread range, or with added trims or notes.

See “Convert” on page 29.

Send the selected embroidery to the 
mySewnet™ cloud for your mySewnet™ 
enabled embroidery machine.

See “Send to mySewnet™” on page 28.
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5 Click Icon view  (the first button). You can now see the .vp4 embroidery files in the 
Landscapes folder as thumbnail pictures.

6 Click Column view  again, 
and click Lighthouse3. The 
lighthouse design is shown on 
the right.

7 Click Coverflow view  (the 
fourth button). Click on the 
lighthouse design. You can 
now swipe to view the other 
designs.

8 Return to Icon view .
9 Select Wild Rose Fence.vp4.
10 Control–click and choose 

Quick Look.

The embroidery worksheet appears, showing a picture of the embroidery, the color blocks 
used, the stitch count, the number of colors, the dimensions, and the Notes.

11 Control–click Wild Rose Fence.vp4 again and choose Get Info.
Some information on the embroidery appears, including the date 
modified, number of colors, stitches, the dimensions and Notes.
Note: From the Open With option on the pop-up menu you can choose 
to open the embroidery in PREMIER+™ 2 Embroidery or PREMIER+™ 
2 Modify. You can also choose Open With from the Quick Look or Get 
Info windows. 
If desired, use the Get Info window to choose an application to open all 
embroidery files (for example, PREMIER+™ 2 Modify), so that when you 
double-click on a file it opens in your chosen application.

12 Open the Preview. A picture of the design appears.
13 Control–click Wild Rose Fence.vp4 again and choose Services.

Use Premier+ 2 Send Express to send the embroidery to the screen of 
the connected embroidery machine.
Use Premier+ 2 Send to send the embroidery to the MyFiles or Personal 
Files folder of the connected embroidery machine.
Use Premier+ 2 Print to print the worksheet for the embroidery, using 
the settings selected in PREMIER+™ 2 Embroidery.
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14 Use Premier+ 2 Send to mySewnet™ to send the embroidery to the mySewnet™ cloud for 
your mySewnet™ enabled embroidery machine.

15 Use Premier+ 2 Convert to create a copy of the embroidery in 
another embroidery format, with a different thread range, or 
with added trims or notes.
Note: PREMIER+™ 2 Machine Communication owners may only 
convert to .vp3 or .vp4.

16 Close the Wild Rose Fence.vp4 Info window, then click Column 
view .

17 Browse to Home/Premier+2/Samples/. This folder contains 
pictures and embroidery files.

18 In the Spotlight  text box, enter a keyword to search, for 
example, "Rose".

19 Click Icon view .
20 The search has been made on the whole computer, and any file with the word "rose" in it is 

listed. In Search, select "Samples".
You can now see thumbnail pictures for embroidery (.vp4 and .edo) and picture (.jpg) files.

21 To the right of the window, click +. A second search bar appears.
22 In the "Any" pop-up menu, choose Other, and enter "embroidery" in the text box. Only 

embroidery files are now displayed.
Note: If you had performed this search on the whole of your computer, all embroidery files 
on your Mac would be listed.

23 To the right of the window, click +. A third search bar appears.
24 Click the "Kind" pop-up menu and choose Other. A list of attributes to search on appears.

You can choose embroidery features, for example number of colors, in these pop-up menus.
25 Scroll down to "Embroidery" to see the 

details you can search for.
26 Click Cancel.

You can construct very complex searches 
using these features.

27 To the right of the window, click Save.
28 Give your search a name and save it. Use 

this feature to save a search for 
embroideries to the sidebar, for easy 
access.

29 Close the Finder window to finish 
searching.

Finder Plugin Options
The following options are available from the context menu.

Open
Open the selected embroidery in the default PREMIER+™ 2 Embroidery System 
app.

■ Control–click an embroidery and choose Open.
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Open With
Choose an app to open the selected embroidery(ies) from the context menu. The 
default PREMIER+™ 2 Embroidery System app is at the top of the list.

Note: Use Get Info to change the default app for opening embroideries.

■ Control–click an embroidery and choose Open With, then choose an app from 
the context menu.

Get Info
View information on the selected embroidery(ies), or open them in the selected 
PREMIER+™ 2 Embroidery System app. See “Get Info” on page 27.

■ Control–click an embroidery and choose Get Info.

Quick Look
View full information for the selected embroidery. See “Quick Look” on page 26.

■ Control–click an embroidery and choose Quick Look.

Services

Premier+ 2 Send Express and Premier+ 2 Send
Use PREMIER+™ 2 Machine to send embroideries directly to the embroidery 
machine screen of some HUSQVARNA VIKING® or PFAFF® machines, or to the 
embroideries folder on the machine. See “Sending Embroideries” on page 18.

• Use Premier+ 2 Send Express to send the selected embroidery to the screen of 
the connected embroidery machine.

• Use Premier+ 2 Send to send the selected embroidery, or embroideries, to the 
MyFiles or Personal Files folder of the connected embroidery machine.

■ Control–click an embroidery and choose Services > Premier+ 2 Send Express.
■ Control–click an embroidery and choose Services > Premier+ 2 Send.

Premier+ 2 Print
Print a worksheet for the selected embroidery (ies), according to the selected 
printer in System Preferences, and options set in PREMIER+™ 2 Embroidery.

■ Control–click an embroidery and choose Services > Premier+ 2 Print.

Premier+ 2 Convert
Create a copy of the selected embroideries in another embroidery file format, with 
a different thread range, or with added trims or notes. See “Convert” on page 29.

■ Control–click an embroidery and choose Services > Premier+ 2 Convert.
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Premier+ 2 Send to mySewnet™
Send the selected embroidery to the mySewnet™ cloud for your mySewnet™ 
enabled embroidery machine, or to your mySewnet™ enabled embroidery 
machine via the mySewnet™ cloud. See “Send to mySewnet™” on page 28.

■ Control–click an embroidery and choose Services > Premier+ 2 Send to 
mySewnet™.

Quick Look
View full details about an embroidery in its 
Quick Look worksheet, including the thread 
name and shade, the design information, and 
the Notes and Technical information.

Open With
Open the selected embroidery in the app 
mentioned on the button.

Note: Change the default app for opening 
embroideries in Get Info. See “Get Info” on 
page 27.

Design Information
The dimensions (Height and Width), Stitch 
Count, and number of colors for the selected 
embroidery are shown in the Design 
Information.

Color Information
A table shows the thread colors and thread ranges used in the selected 
embroidery, and the stitch count for each color.

Note: You may need to use the horizontal scroll bar to see all the color information 
in the table.

Notes and Technical Information
View any notes included with the embroidery, and its position relative to the 
center of the hoop.

Use Quick Look to View an Embroidery
1 Select the embroidery that you want to view.
2 Control–click it and in the context menu select Quick Look. The Quick Look window 

opens.
The design information, thread colors, notes, and technical information for the embroidery 
is shown.

3 Click Open with... to open the embroidery in the selected app.
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Get Info
View details about an embroidery in its Get Info window, 
including the name, date modified, number of colors, 
stitches, the dimensions and Notes.

Use the Get Info window to change the default app for 
opening the selected embroidery, or for all embroideries 
of that type.

Note: If multiple embroideries are selected, a Get Info 
window is opened for each embroidery.

General: The General information includes the name, 
file type, file size, address, and date of creation and 
modification.

More Info: The More Info section includes the number 
of stitches, colors, dimensions, and Notes and Settings.

Open With
Use Open With to change the default app for opening 
the selected embroidery when it is double-clicked. To 
open all embroidery files of this type with that app, use 
Change All.

■ Choose an app in the Open With pop-up menu (for example, PREMIER+™ 2 
Modify) to always open the selected .vp4 embroidery in the chosen app when the 
file is double-clicked. Click the Change All button to open all .vp4 files in that app 
when double-clicked.
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Send to mySewnet™
Use Send to mySewnet™ to send the selected embroidery to the mySewnet™ 
cloud for your mySewnet™ enabled embroidery machine, or to your mySewnet™ 
enabled embroidery machine via the mySewnet™ cloud.

Note: The settings in the Export window are used when sending to mySewnet™. 
See “Export” on page 12.

Send an Embroidery to mySewnet™
1 In Finder, Control–click an embroidery.

Note: You can send any supported embroidery file format.
2 In the context menu, choose Services > Premier+ 2 Send to mySewnet™.
3 In the Send to mySewnet™ dialog click Send to mySewnet™ to send the embroidery to 

your mySewnet™ cloud storage.
4 To send the embroidery via WiFi to your mySewnet™ enabled embroidery machine, click 

the machine’s name in the Send to Machine via mySewnet™ section.
Note: Set the machine’s nickname on the machine itself.
Connect to your mySewnet™ account in the Connection tab of PREMIER+™ 2 Configure. 
See “Connection” on page 16.

Send the design to the mySewnet™ cloud

Send to your machine via the mySewnet™ cloud
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Convert
Use Premier+ Convert to create a copy of the embroidery in another embroidery 
file format, with a different thread range, or with added trims or notes.

Note: PREMIER+™ 2 Machine Communication owners may only convert to .vp3 or 
.vp4.

Convert an embroidery
■ Control–click an embroidery or embroideries and choose Services > Premier+ 

Convert. Select the desired Output File Type and Output Folder and click OK. The 
selected embroideries are converted and saved in the selected folder. 

Note: If an embroidery file already exists with the same name, a message appears.

Convert a Group of Butterfly Embroideries
1 Click the Finder icon  in the Dock to open it.
2 Click Column view  (the third button).
3 Browse to Home/Premier+2/Samples/Finder/Stitch/Animals.
4 Click Icon view  (the first button). You can now see the .vp4 embroidery files in the 

Animals folder as thumbnail pictures.
5 Use Command–click to select all of the butterfly designs.
6 Control–click and in the context menu choose Services > Premier+ Convert. The Convert 

dialog opens.
7 In the Output Folder pop-up menu, ensure that the folder is set to Home/Premier+2/My 

Designs.
8 Click the Output File Types button. The Export dialog opens.
9 In the File Format pop-up menu, set the file type to Compucon / Singer (.xxx).
10 Click OK, then click OK again in the Convert dialog. Copies of the butterfly embroideries 

will be created in .xxx format.
11 Browse to the folder Home/Premier+2/My Designs to view the converted files.

Select the embroidery file type for exporting

Choose the export folder for the converted embroidery

Add trims before stop commands and color changes
Use a different thread range in the exported embroidery

Add notes to the embroidery file

Select a thread range
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Output File Type
Click the button to view the Export dialog where you can select an embroidery file 
format for exporting the converted files. See “Export” on page 31.

The preferred file format for exporting embroideries is Husqvarna Viking / Pfaff 
.vp3, as this will preserve thread color information and notes.

You can also export embroideries as Brother/Baby Lock/Bernina PEC (.pec), 
Brother/Baby Lock/Bernina PES (.pes), Compucon/Singer PSW (.xxx), Husqvarna 
(.hus, .shv), Husqvarna Viking /Pfaff (.vp4, .vp3 and .vip), Janome (.jef and .sew), 
Melco Expanded (.exp), Pfaff (.pcs), Tajima (.dst) or Toyota (.10o).

Output Folder
Select the folder where the converted files should be saved. This is initially set to 
Home/Premier+2/My Designs.

VP4/VP3 Options

Add Trim Commands
Use the Add Trim Commands function to add Trim commands before most 
movement stitches in the selected embroideries.

Note: Trim commands are added before movement stitches using the same criteria 
as for PREMIER+™ 2 Modify. If an embroidery with added Trim commands does 
not display as desired, open it in PREMIER+™ 2 Modify and use Insert Trim  on 
the Modify page of the control panel to add individual Trim commands as desired.

Change Thread Range
Use ’Change Thread Range to’ to convert the colors in an embroidery to a chosen 
thread range, including a My Thread range. Any selected embroideries are 
converted.

■ Choose a thread range from the Change Thread Range pop-up menu, and click OK 
to change the thread range.

Note: In other PREMIER+™ 2 Embroidery System apps you can use Thread Range 
in the Color Tone dialog to change the thread range for an embroidery without 
adjusting other settings.

Use Change Thread Range to convert embroideries to any of the thread ranges 
available in the PREMIER+™ 2 Embroidery System. For instance, you may convert 
embroideries to a My Thread range, to see which threads to use from your 
personal thread collection.

Add Extra Notes
Click Add Extra Notes to open the Notes dialog. See “Notes” on page 35.

Note: This is only available when converting to .vp4 or .vp3 embroidery file format.
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Export
Save the project in the current window in the desired format according to the 
chosen options to optimize for sewing. The embroidery must fit in the currently 
selected hoop. Use the Design Player to see how the embroidery will be exported 
according to the current Optimize for Sewing Options.

The preferred file format for exporting embroideries is Husqvarna Viking / Pfaff 
.vp4, as this will preserve thread color information and notes.

You can also export embroideries as Brother/Baby Lock/Bernina PEC (.pec), 
Brother/Baby Lock/Bernina PES (.pes), Compucon/Singer PSW (.xxx), Husqvarna 
(.hus, .shv), Husqvarna Viking /Pfaff (.vip), Janome (.jef and .sew), Melco Expanded 
(.exp), Pfaff (.pcs), Tajima (.dst) or Toyota (.10o).

Optimize for Sewing Options
All of these options are initially selected when saving as a .vp4 file, or in any other 
format.

Note: You can customize the Optimize for Sewing Options in PREMIER+™ 2 
Configure.

Combine: Merge the embroideries into a single embroidery during Export. 

Note: Combine is not enabled if there is only one design, and for embroidery 
formats that are automatically combined.

Remove Overlap: Prevent areas of stitches building up where embroideries 
overlap.

Remove Overlap is not available when Combine is not enabled.

Note: Only deselect this option if, for example, your embroideries are low density 
and you wish to have a blend effect where they overlap. Also, some multipart 
embroideries are created with areas that are designed to overlap each other near 
the mid-section of a turnable hoop. When viewing these designs in PREMIER+™ 2 
Embroidery, deselect Remove Overlap before exporting. Deselect Remove 
Overlap in PREMIER+™ 2 Configure, Export, before sending them to the 
embroidery machine.

Choose an embroidery format

Optimize the embroidery for 

Go to the "Save" or "Saving as" dialog

Set the options for splitting 

Create placement stitches 

Rotate the hoop to suit your machine

stitching out

for decorations

in a multipart hoop
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ColorSort: Reduce the number of thread colors during Export. 

Optimize Stitch Length: Automatically remove small and insignificant stitches. 
See “Optimize Stitch Length” on page 34.

Note: Cutwork Needle lines in the Inspira Cutwork Needle "thread range" are 
unaffected by Optimize Stitch Length.

Decoration
Create Center or Line placement stitches for Decorations added in PREMIER+™ 
2 Embroidery Extra, or remove all decorations and their associated placement 
stitches.

Center or Line placement stitches are created automatically for decorations 
according to the options set in PREMIER+™ 2 Configure, which may be altered 
when you export the embroidery. Alternatively, create crystal transfer templates 
for automated cutters with Export Decoration Template in PREMIER+™ 2 
Embroidery.

Center placement stitches are recommended when most decorations are 
individual and symmetrical. Line placement stitches are recommended when most 
decorations are individual and asymmetrical (such as bugle beads) or lines of 
closely spaced beads or sequins.

Hoop Orientation
These options are not available.

Splitting options
Click the button to open the splitting options dialog. See “Splitting for Multipart 
Hoops” on page 33.

Additional Sections
Additional dialog sections are available, depending on the chosen file format.

• If .vp3 or .vp4 is chosen, Splitting for Multipart Hoops is present. See “Splitting 
for Multipart Hoops” on page 33.

• If .pes is chosen, you can select your machine type, file version, hoop size and 
rotation.

• If .jef is chosen, you can select your machine type, hoop size and rotation.

Next
View the Save, or Saving As dialog, depending on the selected file format.

Export an Embroidery
1 Click the Finder icon  in the Dock to open it.
2 Browse to the desired folder and use Command–click to select the desired embroidery.
3 Control–click and in the context menu choose Services > Premier+ Convert. The Convert 

dialog opens.
4 Click the Output File Types button. The Export dialog opens.
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5 In the File Format pop-up menu, choose a file type.
6 Select your optimization options.
7 If you are using a multipart hoop, set Intelligent or Straight Line split.
8 Click OK, then click OK again in the Convert dialog. Copies of the embroidery are created 

in the chosen format.

Splitting for Multipart Hoops
Note: This section appears if .vp4, .vp3 or .pes is selected as the file format.

Embroideries for Multipart hoops are split automatically, according to your Export 
settings. Use an Intelligent or Straight Line Split.

Note: There is no need to ensure embroideries are in one stitch area of the hoop; 
just place your embroideries in the most pleasing arrangement. 

Split Method
You can use one of two split methods:

• Intelligent Split automatically calculates a split line that cuts the minimum 
number of stitches, and minimizes cuts through solid sections of embroidery. 
Where possible, use Intelligent Split.

• Straight Line Split cuts the embroidery straight across the center line of the 
overlap zone.

Intelligent with Tolerance
Intelligent Split calculates a split line that cuts the minimum number of stitches, and 
minimizes cuts through solid sections of embroidery. For example, a large 
embroidery is split at a narrow section, and an embroidery that fits in one stitch 
area of the hoop is left in one piece even if it is part of a larger design.

Tolerance ensures that the Intelligent Split line stays a short distance from the 
edges of the overlap. This allows for play in the hoop when going from one hoop 
area to another, such as when aligning a hoop that has been turned to stitch out 
the other side of an embroidery.

You can set Tolerance from 0 to 3mm, in steps of 1mm. The initial setting is 1mm.

Use Intelligent Split with Tolerance
■ Select the "Intelligent with Tolerance" checkbox, then enter a number in the 

Tolerance number box, or use the arrows to increase or decrease the Tolerance.

Straight with Compensation
Straight Line Split cuts straight across the center of the overlap zone. Straight Line 
Split will only split an individual embroidery if, before it is combined with 
everything else, it does not fit entirely into one stitch area of the hoop.

Note: Lettering is split straight down the middle, as with any other type of 
embroidery. This may cut through characters rather than gaps and spaces. In such 
cases, it is recommended to use Intelligent Split instead.
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Compensation adds overlapping stitches along the edges where the embroidery 
is split. This compensates for pull on the fabric.

Alignment Stitch for Turnable Hoops
Select this option to add an alignment cross at the end of the first embroidery 
section when using the HUSQVARNA VIKING® Designer Majestic™, PFAFF® 
creative Grand Dream™, Universal Multipart hoop or Brother Jumbo Frame 
Hoop. A hoop movement to the alignment cross is added at the beginning of the 
next section. The next embroidery section can then be correctly aligned, or 
alignment can be confirmed.

Optimize Stitch Length
Use Optimize Stitch Length to automatically remove small and insignificant 
stitches.

Stitch Length Sensitivity
Adjust the sensitivity of the optimization. Low is set as the default.

■ Choose Low, Medium or High from the pop-up menu.

Minimum Significant Stitch Length
Select the shortest stitch length that you consider to be significant. Stitches below 
this length are removed during the optimization process. The default stitch length 
is 0.8 mm.

Note: Cutwork Needle lines are unaffected by the Minimum Significant Stitch 
Length.

■ Choose 0.6 mm, 0.8 mm or 1.0 mm from the pop-up menu.

None Use None if you can split an embroidery without cutting through any of the 
design elements. Compensation is initially set to None.

Low Use Low when cutting through a lightly stitched embroidery or when the split 
lines go through only a few stitch areas.

High Use High when the embroidery is dense, when the split lines make long splits 
through stitch areas, or when stitching onto materials such as knitted or 
stretchy fabric.

Adjust the sensitivity
Set your shortest desired stitch length
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Notes
The Notes dialog allows free text and keywords 
to be added to the Notes for the selected 
embroidery. Enter additional Notes in the Notes 
box.

Note: Add a keyword or phrase to all 
embroideries when converting a group.

Up to 2000 characters can be entered in the 
Notes.

Note: If the Notes in any embroidery file is more 
than 2000 characters long after adding the new 
Notes, only the first 2000 characters will be 
retained.

Keywords
Select Keywords for the embroidery from the list, 
then click Add to add them to the Notes for the 
embroidery.

Edit the Notes for an Embroidery
1 Select the embroidery that you want to add notes to.
2 Control–click and in the context menu choose Services > Premier+ Convert. The Convert 

dialog opens.
3 Click Add Extra Notes.
4 In the Notes text box make your desired changes to the Notes.

Note: Use Option–Return or Control–Return to start a new line of text.
5 To add Keywords, select the keyword from the Category heading or subcategory in the 

scrolling list. Then click Add to add them to the Notes.
6 Click OK to save your amended Notes and added keywords.

Searching for Embroideries
Use Spotlight to find embroideries by name, and from information in the notes and 
settings. You can also search on other properties, and sort your search results.

Sorting Files in List View
Use the headers at the top of the columns in List  view to sort files. For 
example, click the Name header to place files in alphabetical order, or sort by the 
date of creation or modification.

■ Click a header in List view. The files are sorted using that header. 

Note: To change the headers, Control–click one of the headers and add or remove 
headers from the context menu.
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Search for Embroideries by Name and in the Notes
1 Click the Finder icon  in the Dock to open it.
2 Click Column view  (the third button).
3 Browse to Home/Premier+2/Samples/Modify/Stitch.
4 Click Icon view  (the first button). You can now see the .vp4 embroidery files in the 

Stitch folder as thumbnail pictures.
5 In the Spotlight text box, 

enter the word ’flower’.
6 In Search, click "Stitch" to 

search only the current 
folder. Thirteen items are 
found.

7 All of the embroideries 
except ButterfliesHoodie.vp4 
have "flower" in their name. 
Control–click 
ButterfliesHoodie.vp4 and 
choose Quick Look in the 
context menu.

8 Scroll down in the Quick Look window. The word "Flowers" is present in the Notes.
Spotlight searches in the embroidery Notes and Settings, as well as for the file and folder 
name.

9 Close the ButterfliesHoodie Quick Look window.
10 In the Spotlight text box, enter the word ’diamond’. The Raygun2HatBadge embroidery is 

listed.
11 Control–click the Raygun2HatBadge embroidery and choose Quick Look. In the Quick 

Look window, scroll down to the Settings. The Settings includes information on the 
Diamond style used in the Crosshatch fill.
Note: A search may produce unexpected results. Check the Notes and Settings, as well as 
the folder name, to reveal the reason for a surprising result.

12 Close the Raygun2HatBadge Quick Look window.
13 In the Spotlight text box, enter the word ’flower’ again.
14 To the right of the window in the Search bar, click +. A second search bar appears.
15 In the "Kind" pop-up menu, choose Embroidery Notes, and enter "flowers" in the text box.

Only one embroidery is found, 
ButterfliesHoodie.vp3. It uses the 
word flowers in its Notes.
Note: This method of searching looks 
only at the Notes. It can be used to 
exclude unexpected results from the 
name, settings, or folder name. To 
search for information in the Settings, 
in the pop-up menu choose 
’Embroidery Settings’ instead of 
’Embroidery Notes’.

16 Delete the last four letters from ’flowers’ in the second search bar to make ’flo’. Many more 
embroideries are now displayed, as they had ’floral’ in their Notes, not ’flowers’. You can 
search on incomplete words, as well as complete words.
Note: Use ’Embroidery Notes’ and ’Embroidery Settings’ as well as other properties such as 
’Embroidery Stitches’ to search for embroidery information in Spotlight.
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Search Types
Use the following search types to search for embroidery properties. 

Refining a Search
Use Search to look for files in nested folders, and refine and sort the results to 
view them.

1 Click the Finder icon  in the Dock to open it and use Column view  to browse to 
Home/Premier+2/Samples/Finder/Stitch. The folders within the Stitch folder are displayed.

2 Click Icon view .
3 In the Spotlight text box, enter the word ’flower’, and in Search, click "Stitch" to search only 

the current folder. There are 46 items in the search results.
4 Look at the list of results. It includes the folder Flowers.

Note: The search results include the contents of the folders within the Stitch folder, and the 
names of the folders.

5 To the right of the window, in the Search bar, click +. A second search bar appears.
6 In the "Any" pop-up menu, choose Other, and enter "embroidery" in the text box. Only 

embroidery files are now displayed.
Note: If you had performed this search on the whole of your computer, all embroidery files 
on your Mac would be listed.

7 Look at the names of the embroidery files. The flowers use varied embroidery file formats.
8 To the right of the window, in the second Search bar, click +. A third search bar appears.
9 In the pop-up menu on the left, choose Name.
10 In the pop-up menu to the right, 

choose "contains".
11 Enter the phrase "vp4" in the text 

box. Only embroideries in .vp4 
format are now displayed.

12 You can also search for part of a 
file name this way. Enter the 
word "magic". Fourteen 
embroideries in varying formats 
are shown.

Search Term Items Searched

Embroidery Notes Search within the embroidery Notes.

Embroidery Settings Search within the embroidery Settings information.

Embroidery Stitches The number of stitches in the embroidery.

Embroidery Colors The number of thread colors used in the embroidery

Embroidery Width (mm) The width of the embroidery in millimeters.

Embroidery Height (mm) The height of the embroidery in millimeters.

Embroidery Width (") The width of the embroidery in inches.

Embroidery Height (") The height of the embroidery in inches.
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You can refine a search in other ways. To exclude all ’flower’ embroideries with the word 
’metallic’ in their name or notes, do as follows.

13 To the right of the window, click - 
to remove the third search bar.

14 Ensure that the "Any" pop-up 
menu is set to Other, and 
"embroidery" is entered in the 
text box to display only 
embroidery files.

15 In the Spotlight text box, enter 
the phrase:
flower NOT metallic
None of the 28 files displayed 
have ’metallic’ in their name or 
notes.
Note: The word ’NOT’ excludes any file containing the word that follows it. When used in 
this way, NOT must use uppercase letters.

16 Enter the phrase ’flower AND metallic’.
All of the 13 files displayed have both of the words ’flower’ and ’metallic’ in their name or 
notes. AND is a powerful way of narrowing a search.

17 You can also search using the operator ’OR’. This searches for files and folders using either 
the word ’flower’ or the word ’metallic’. Enter the phrase: flower OR metallic

18 To perform advanced searches, you can combine searches. Enter the phrase:
(flower AND metallic) OR (farmyard AND bird)
In addition to the metallic flower embroideries found previously, Goose, Hen and Rooster 
from the Animals folder are also displayed. Place searches within parentheses to combine 
them.

Search Operators
Use the following uppercase search operators when searching:

Search Operator Items Searched

AND Search for items containing both terms.

OR Search for items containing either term.

NOT Search for items that use the first term, but do not use the second.
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Searching for Files by Size and Number of Colors
Use Spotlight to find embroidery files by their size, or the number of stitches.

1 Click the Finder icon  in the Dock to open it and use Column view  to browse to 
Home/Premier+2/Samples/Finder/Stitch. The folders within the Stitch folder are displayed.

2 In the Search text box, enter the word ’farmyard’. Nine items are found.
3 Click List view .
4 At the top of the List view, click the Size header. The search results are sorted by file size.

This is a very quick way to see the approximate size of embroidery files, but using the stitch 
count is a better guide.
Note: If the Size header is not there, Control–click one of the headers and add Size from the 
context menu.

5 Click Icon view .
6 To the right of the window, in the Search bar, 

click +. A second search bar appears.
7 In the pop-up menu on the left, choose 

Embroidery Stitches.
8 In the pop-up menu to the right, choose 

"equals".
9 In the Embroidery Stitches text box, enter the 

number ’3433’. The embroidery Hen is found.
Embroidery Stitches in this form searches on the exact number of stitches. It would be 
more useful to search within a range.

10 In the pop-up menu to the right, choose "is less than".
11 In the Embroidery Stitches text box, enter the number ’7000’. If you check with Quick 

Look, you will see that all of the embroideries listed contain fewer than 7000 stitches.
12 In the pop-up menu to the right, choose "is greater than".

In the Embroidery Stitches text box, enter the number ’15000’. Only a single embroidery in 
the Stitch folder with more than 15,000 stitches is displayed.

13 As with searching on name and notes, you can combine searches.
14 Set the number back to ’7000’.
15 To the right of the window, in the second Search bar, click +. A third search bar appears.
16 In the pop-up menu on the left, choose Embroidery Stitches.
17 In the pop-up menu to the right, choose "is less 

than".
18 In the lower Embroidery Stitches text box, enter 

the number ’15000’. 
19 If you check with Quick Look, you will see that 

all of the embroideries listed contain more than 
7000 stitches, but fewer than 15,000 stitches.

20 Searching on number of colors is very similar. 
Delete the text from the Spotlight text box at 
the top.

21 To the right of the window, click - to remove the third search bar.
22 In the pop-up menu on the left, choose Embroidery Colors.
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23 In the pop-up menu to the right, choose "equals".
24 In the Embroidery Colors text box, enter the 

number ’1’.
All embroideries in the Stitch folder using only 
one thread color are displayed.
Note: This is a useful way of searching for 
Redwork embroideries if you did not add the 
term to the Notes.

25 In the pop-up menu to the right, choose "is 
greater than".

26 In the Embroidery Colors text box, enter the number 10. All embroideries in the folder 
with more than ten colors are listed.
Similarly if the menu on the right is set to ’is less than’, all embroideries with fewer than ten 
colors are shown. If the third search bar is set to Embroidery Colors as well, embroideries 
with a range of number of colors can be shown (for example, more than five, but fewer than 
ten).

Searching for Embroideries by Width, Height and Hoop Size
The methods used when searching for embroideries by width and height are the 
same as those when searching by stitch count and number of colors.

1 Click the Finder icon  in the Dock to open it and use Column view  to browse to 
Home/Premier+2/Samples/Finder/Stitch. The folders within the Stitch folder are displayed.

2 In the Spotlight text box, enter the word ’floral’, and in Search click "Stitch" to search only 
the current folder.

3 To the right of the window, in the Search bar, click +. A second search bar appears.
4 In the pop-up menu on the 

left, choose Embroidery 
Width (mm).

5 In the pop-up menu to the 
right, choose "is less than".

6 In the Embroidery Width 
text box, enter the number: 
100
This searches for all 
embroideries in the folder 
that are narrower than 
100mm. There are 14 such 
embroideries.

7 In the pop-up menu on the left, choose Embroidery Height (mm), in the pop-up menu to the 
right ensure that "is less than" is selected, and that the number is still 100. This time 15 
embroideries are found.
You can combine the two searches to show all embroideries that will fit within a 100mm x 
100mm hoop.

8 In the pop-up menu on the left, choose Embroidery Height (mm), in the pop-up menu to the 
right ensure that "is less than" is selected, and that the number is set to 100.

9 To the right of the window, in the second Search bar, click +. A third search bar appears.
10 In the pop-up menu on the left, choose Embroidery Width (mm).
11 In the pop-up menu to the right, choose "is less than".
12 In the Embroidery Width text box, enter the number: 100. This search displays 14 items. 
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Similarly, you could search for any embroideries too big to fit in your largest hoop: 
Set Embroidery Width (mm) to greater than 360, and Embroidery Height (mm) to greater 
than 350.

13 To search for embroideries within a range of hoop sizes, use four search bars. Set one 
Width and Height to your smallest hoop size, for example 100 x 100, and one to your 
largest hoop size, for example 260 x 200.

Universal Hoop Dimensions
These are the Universal hoop dimensions in millimeters for a search to find 
embroideries that will fit within the stated hoop and orientation:

Universal Hoop Size (mm) Search Phrase

Square Hoop 1 100 x 100 Embroidery Width (mm) is less than 100
Embroidery Height (mm) is less than 100

Square Hoop 2 150 x 150 Embroidery Width (mm) is less than 150
Embroidery Height (mm) is less than 150

Square Hoop 3 200 x 200 Embroidery Width (mm) is less than 200
Embroidery Height (mm) is less than 200

Midsize Hoop 1
(Vertical)

100 x 170 Embroidery Width (mm) is less than 100
Embroidery Height (mm) is less than 170

Midsize Hoop 1
(Horizontal)

170 x 100 Embroidery Width (mm) is less than 170
Embroidery Height (mm) is less than 100

Large Hoop 1
(Vertical)

130 x 180 Embroidery Width (mm) is less than 130
Embroidery Height (mm) is less than 180

Large Hoop 1
(Horizontal)

180 x 130 Embroidery Width (mm) is less than 180
Embroidery Height (mm) is less than 130

Large Hoop 2
(Vertical)

150x 240 Embroidery Width (mm) is less than 150
Embroidery Height (mm) is less than 240

Large Hoop 2
(Horizontal)

240x 150 Embroidery Width (mm) is less than 240
Embroidery Height (mm) is less than 150



42          PREMIER+™ 2 Configure   Finder Integration & Spotlight 

Large Hoop 3
(Vertical)

200 x 260 Embroidery Width (mm) is less than 200
Embroidery Height (mm) is less than 260

Large Hoop 3
(Horizontal)

260 x 200 Embroidery Width (mm) is less than 260
Embroidery Height (mm) is less than 200

Large Hoop 4
(Vertical)

200 x 360 Embroidery Width (mm) is less than 200
Embroidery Height (mm) is less than 360

Large Hoop 4
(Horizontal)

360 x 200 Embroidery Width (mm) is less than 360
Embroidery Height (mm) is less than 200

Multipart Hoop 1
(Vertical)

350 x 360 Embroidery Width (mm) is less than 350
Embroidery Height (mm) is less than 360

Multipart Hoop 1
(Horizontal)

360 x 350 Embroidery Width (mm) is less than 360
Embroidery Height (mm) is less than 350
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7Troubleshooting

Error Messages
Installation

"This package will run a program to determine if the software can be 
Installed."
This message appears when installing the Samples. Click Continue to proceed with 
the installation if the software has already been activated. Otherwise, activate your 
software, and then install the Samples.

"Feature not available in this version."
This message will appear when trying to start a module or feature if the 
PREMIER+™ 2 Embroidery System cannot detect an activation for that module or 
feature. Ensure that you have activated your software.

Your license may not cover this module or feature. To upgrade, see your dealer or 
look in the Purchase Center at: www.EmbroideryPurchaseCenter.com

Using PREMIER+™ 2 Embroidery System Apps

"Feature not available in this version."
This message will appear when trying to start a module or feature if the 
PREMIER+™ 2 Embroidery System cannot detect an activation for that module or 
feature. Ensure that you have activated your software.

Your license may not cover this module or feature. To upgrade, see your dealer or 
look in the Purchase Center at: www.EmbroideryPurchaseCenter.com

Send to Embroidery Machine

"System Error. Please close and restart all software."
This message appears if there are issues with the memory handling of your system 
that make communication with your embroidery machine temporarily unavailable. 
Close and restart all apps and try again. If this does not solve the issue, restart 
your computer.

Setting Export Options

"The value ’*mm’ needs to be in the range 1 to 3mm. Please provide a valid 
value."
This message appears if the tolerance value entered in the box on the Export tab is 
below 1mm or above 3mm, or is not a number. Enter a number within the valid 
range.
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Setting Appearance Options

"The value ’*mm’ needs to be in the range 5 to 200mm. Please provide a 
valid value."
This message appears if the value entered in the Real Size box on the Appearance 
tab is below 5mm or above 200mm, or is not a number. Enter a number within the 
valid range.

Using Backup and Restore My Settings

"Restoring your settings will overwrite the current settings."
This message is displayed when you click Restore My Settings in the Utilities tab. 
Click OK, or click Cancel to keep your current settings.

Using Reset All Apps

"Reset All Apps: To reset all applications correctly, you must ensure that no 
PREMIER+™ 2 apps are open."
This message is displayed if you select Reset All Apps in the Utilities tab while 
other PREMIER+™ 2 Embroidery System apps are running. Click Cancel, or use 
Quit Open PREMIER+™ 2 Apps to close all open apps.

"Application could not be shut down. PREMIER+™ 2 XX could not be quit. 
Please shut this app down manually."
This message is displayed if you select Quit Open PREMIER+™ 2 Apps in Reset All 
Apps when, for instance, a dialog is open or you have unsaved changes in a 
PREMIER+™ 2 Embroidery System app. Click OK, and then shut the app down 
manually.
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Other Topics
Using PREMIER+™ 2 Machine

"I cannot send a design to my embroidery machine."
First, confirm that the PREMIER+™ 2 Machine app is running. PREMIER+™ 2 
Machine appears as a machine icon  in the menu bar.

If PREMIER+™ 2 Machine is not running, start it.

■ Click the PREMIER+™ 2 Machine icon in the Launchpad , or double-click the 
PREMIER+™ 2 Machine icon in the Finder .

Second, confirm that the PREMIER+™ 2 Machine app is communicating with your 
embroidery machine.

■ Click the machine icon in the menu bar and check that your embroidery machine is 
listed in the menu. If it is not, check the USB connection, then choose Quit and 
start PREMIER+™ 2 Machine again.

Note: If the USB connection between your embroidery machine and computer is 
temporarily interrupted, you may need to restart PREMIER+™ 2 Machine.

"Can I set the PREMIER+™ 2 Machine app to automatically start when I 
turn on my computer?"
Yes, you can set PREMIER+™ 2 Machine to start automatically as follows:

1 Click System Preferences  in the Dock.
2 In the System area click Users & Groups.
3 In Users & Groups, ensure that your user account is selected under Current User.
4 Click the Login Items tab.
5 Click the + button towards the bottom of the window. A Finder window appears.
6 In the pane on the left, click Show to open the Favorites list.
7 Select Applications in Favorites.
8 In the pane on the right, scroll down to the PREMIER+™ 2 Machine entry.
9 Select PREMIER+™ 2 Machine, then click Add.

PREMIER+™ 2 Machine is now in the list of items that automatically start when you log in.
10 Close Users & Groups and System Preferences.

When you next log into your computer, the PREMIER+™ 2 Machine icon  will 
appear in the menu bar.

"Can I connect more than one embroidery machine to my computer with 
PREMIER+™ 2 Machine?"
No, you are not able to connect two embroidery machines at the same time, and 
to send a design to the first embroidery machine and then to the second 
embroidery machine.

If you want to send an embroidery to two machines, do as follows:
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1 Send the design to the first machine.
2 Disconnect the USB connection between your Mac and that embroidery machine.
3 Connect a USB cable between your second embroidery machine and your Mac.
4 Send the design to the second embroidery machine.

"I sent a design to my embroidery machine, but nothing happened."
You can only send a design directly to your embroidery machine if the following 
folder exists: /Library/Application Support/VsmSoftware/Premier+2/TempSend

If this folder does not exist, do as follows:

1 Open a Finder window.
2 In the Go menu, hold down the Option key and choose Library.
3 Browse to Application Support/VsmSoftware/Premier+2.
4 Control–click an empty area of the screen and choose New Folder from the context menu.
5 Name the new folder TempSend.
6 Send the design again.

Send to Embroidery Machine

"I don’t see the PREMIER+™ 2 Machine icon in the menu bar when I start 
my computer."
You have not set PREMIER+™ 2 Machine to run automatically when your 
computer starts. See “"Can I set the PREMIER+™ 2 Machine app to automatically 
start when I turn on my computer?"” on page 45.

Loading Embroideries from a USB Stick

"I exported my embroidery to my USB stick, but I cannot browse to it on 
my embroidery machine."
Your embroidery machine may not be able to read USB sticks with a large capacity. 
Check the manual for your embroidery machine for information on limitations on 
the size of USB stick memory.

"I exported my embroidery to my USB stick, but I cannot find it when I 
browse the stick on my embroidery machine."
You may need to place the embroidery within a particular folder on your USB 
stick. For example, on the Janome MC350E the embroidery files must be placed in 
the EMB5 folder, while for the MC11000 and MC12000 they must be placed in the 
Embf folder.

General Use of Threads

Colors in PREMIER+™ 2 Embroidery System Files
The PREMIER+™ 2 Embroidery System will display threads in a file in the same 
way on any computer where it is installed. That is, the colors used will be the same 
even if they are reproduced slightly differently on different monitors. You can print 
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a worksheet to see the colors and color names used in a particular design. This is 
true, even if you do not have all the threads in a design defined in the database on 
your computer. This is because a PREMIER+™ 2 Embroidery System design has 
complete information for each of the threads it uses.

Each thread used in a design will fall into one of the following categories:

• A thread from the Thread Database.
• A thread from the Thread Database that is not on your own Thread Database 

because your database is out of date.
• A custom thread defined in the file that does not appear in your Threads 

database.

The availability of threads in the Thread Database will only affect parts of the 
PREMIER+™ 2 Embroidery System where you can change colors, as follows:

• Editing apps: PREMIER+™ 2 Embroidery and PREMIER+™ 2 Modify
• Design apps: PREMIER+™ 2 Create

Below are some situations you may encounter according to the availability of 
thread definitions, as categorized above.

"I have a design from another user that uses threads from the Thread 
Database that I do not have."
Use Smart Update to find and download the latest thread database, which you can 
then install.

"I have a vp4 or vp3 embroidery from another user that uses a custom 
thread definition they designed."
If you attempt to change the color the nearest match will be selected. If desired, 
select a replacement thread.
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Registration and Activation

"How do I change my personal information for my software registration?"
Simply click the Register button in PREMIER+™ 2 Configure and repeat the 
registration process. This does not change the registration status of software you 
have already registered, but it does allow you to change your personal information 
and/or dealer information.

The computer with your software is not connected, you will need to enter your e-
mail address and password to find your registration details.

"How do I activate my software?"
You can activate your software when installing. Alternatively, select the Register 
button in PREMIER+™ 2 Configure at any time to activate. Once you have 
activated, your activation code is in your registration entry.

"How can I move my activation to another computer?"
You can move your activation to another computer. 

1 In the Utilities page of  PREMIER+™ 2 Configure click the Activate button and sign in to 
your Registration account. 

2 On the Enter Your Product Activation Codes page click 'I would like to remove my 
Activation from this computer'.

3 Click OK to remove the activation from the computer.
You will then be able to install and activate your software on another computer.
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Thread Colors and Embroidery Machines
Thread Colors and the HUSQVARNA VIKING® Designer 
Diamond Royale, Designer Diamond deLuxe, Diamond, Ruby 
deLuxe and Ruby

Thread Color Representation
When PREMIER+™ 2 Embroidery System embroidery files in .vp3 format are 
displayed on the Ultimate Interactive Screen, the thread colors are displayed 
correctly according to the first color in the thread definition (some threads have 
multiple colors in the thread definition). However, the thread type and weight is 
not used. This means the following:

• All thread types are displayed as if they are rayon, so, for example, metallic 
effects will not be seen

• Threads are displayed with the same thread weight, which is approximately 
equivalent to 40 weight

Ultimate Interactive Screen Display of Colors
While the Ultimate Interactive Screen can display the thread colors correctly 
according to their RGB (red, green, blue) values, some colors may still appear 
different than they do on a computer monitor. This is because of the inherent 
differences in the displays themselves. The same colors can even look different on 
two identical monitors if their brightness, contrast and color settings are different.

Thread Names
Thread names from .vp3 embroidery files are shown on the embroidery machine 
as the first four characters of the thread range abbreviation, the thread weight and 
thread number.

No thread range, thread weight or manufacturer's thread number is shown for 
other file types as this information is not present in other file types. The only 
exception is for .vip embroideries, which shows the thread range for each color in 
the embroidery. This applies when opening embroideries on the machine in their 
native format, rather than sending them from the PREMIER+™ 2 Embroidery 
System.

Thread Conversion
Embroideries other than .vp3 are converted to .vp3 when they are sent from the 
PREMIER+™ 2 Embroidery System. When .vip embroideries are converted, the 
equivalent thread ranges are used. For all other embroidery file formats, the 
threads are converted to the nearest matching color from the Import Thread 
Range chosen in PREMIER+™ 2 Configure.

It is also possible, however, to open embroideries directly by browsing the 
computer from the machine, and to open embroideries that have been placed on a 
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USB stick. In this case, the embroideries are opened in their original format. The 
thread colors will be displayed in the RGB colors used by the file format. The color 
changes are numbered and no thread range or thread number information is 
shown. The only exception is for .vip embroideries, which show the thread ranges 
for colors in the embroidery. To see the thread numbers in a .vip embroidery, send 
the embroidery from the PREMIER+™ 2 Embroidery System.

Saving Embroideries from the Ultimate Interactive Screen
Embroideries are always saved in Husqvarna Viking / Pfaff .vp3 format from the 
Ultimate Interactive Screen. All embroideries and lettering currently on the screen 
are saved in the .vp3 file. Files can be saved to the embroidery machine memory, a 
connected USB stick or a connected computer.

Errors from Undefined Thread Colors in Embroideries Saved from the 
Ultimate Interactive Screen
When a file that does not have full thread definitions is loaded on the Ultimate 
Interactive Screen and then saved in .vp3 format, each color will be saved with only 
the RGB value (this assumes that colors have not been changed on the Ultimate 
Interactive Screen). If the file is later opened in the PREMIER+™ 2 Embroidery 
System, attempting to change such a thread color will give the message that it is 
undefined and it will be automatically converted to the nearest thread color in the 
Import Thread Range set in PREMIER+™ 2 Configure.

Changing Thread Colors to Available Thread Shades
A fixed set of 64 thread shades from the Robison-Anton Rayon 40 range is available 
for changing colors, as follows:

2296 Black 2439 Blue Ribbon

2217 Twilight 2437 Empire Blue

2731 Gull 2527 Soldier Blue

2539 Chrome 2614 Pro Lusty Blue

2297 Snow White 2300 Ice Blue

2335 Ivory 2239 Sky Blue

2298 Taupe 2533 Ozone

2478 Light Cocoa 2577 Wonder Blue

2544 Desert Cactus 2490 Plum Wine

2545 Cypress 2500 New Berry

2221 Willow 2424 Cachet

2241 Palm Leaf 2588 Mid Lilac

2316 Celery 2243 Light Pink

2557 Yellow 2286 Tulip

2264 Chinese Yellow 2287 Mauve

2462 Sunflower 2288 Iris
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If a color in an embroidery is changed to one of these colors, the .vp3 embroidery 
file will contain the full thread definition for that color when the embroidery is 
saved from the Ultimate Interactive Screen. This will be displayed and identified 
correctly if it is loaded into a PREMIER+™ 2 Embroidery System app.

Thread Colors and the HUSQVARNA VIKING® Designer SE

Thread Color Representation
When PREMIER+™ 2 Embroidery System embroidery files in .vp3 format are 
displayed on the Interactive Designer screen, the thread colors are displayed 
correctly according to the first color in the thread definition (some threads have 
multiple colors in the thread definition). However, the thread type and weight is 
not used. This means the following:

• Variegated threads are displayed in the first color in the thread definition
• All thread types are displayed as if they are rayon, so, for example, metallic 

effects will not be seen
• Threads are displayed with the same thread weight, which is approximately 

equivalent to 40 weight

Interactive Designer Screen Display of Colors
While the Interactive Designer screen can display the thread colors correctly 
according to their RGB (red, green, blue) values, some colors may still appear 
different than they do on a computer monitor. This is because of the inherent 
differences in the displays themselves. The same colors can even look different on 
two identical monitors if their brightness, contrast and color settings are different.

2208 Dark Green 2263 Foxy Red

2579 Vibrant Green 2420 Tuxedo Red

2738 Pro Erin 2467 Orangeade

2555 Pastel Green 2253 Flesh Pink

2318 Pale Green 2413 Flesh

2547 Pebblestone 2377 Bisque

2279 Spruce 2237 Carnation

2457 Green Dust 2504 Cherrystone

2607 TH Green 2629 Pro Walnut

2515 Bluestone 2489 Wicker

2518 Indian Ocean Blue 2518 Old Dark Tex Orange

2452 Green Pearl 2289 Rust

2310 Mint Julep 2231 Toast

2313 Sprite 2331 Mustard

2617 Pro Twinkle 2409 Yellow Mist

2309 Teal 2396 Brite Yellow
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Thread Names
Thread names from .vp3 embroidery files are shown on the Designer SE as the first 
four characters of the thread range abbreviation, the thread weight and thread 
number.

No thread range, thread weight or manufacturer's thread number is shown for 
other file types as this information is not present in other file types. The only 
exception is for .vip embroideries, which shows the thread range for each color in 
the embroidery. This applies when opening embroideries on the machine in their 
native format, rather than sending them from the PREMIER+™ 2 Embroidery 
System.

Thread Conversion
Embroideries other than .vp3 are converted to .vp3 when they are sent from the 
PREMIER+™ 2 Embroidery System. When .vip embroideries are converted, the 
equivalent thread ranges are used. For all other embroidery file formats, the 
threads are converted to the nearest matching color from the Import Thread 
Range chosen in PREMIER+™ 2 Configure.

It is also possible, however, to open embroideries directly by browsing the 
computer from the machine, and to open embroideries that have been placed on a 
USB stick. In this case, the embroideries are opened in their original format. The 
thread colors will be displayed in the RGB colors used by the file format. The color 
changes are numbered and no thread range or thread number information is 
shown. The only exception is for .vip embroideries, which show the thread ranges 
for colors in the embroidery. To see the thread numbers in a .vip embroidery, send 
the embroidery from the PREMIER+™ 2 Embroidery System.

Saving Embroideries from the Designer SE Interactive Designer Screen
Embroideries are always saved in Husqvarna Viking / Pfaff .vp3 format from the 
Designer SE Interactive Designer screen. All embroideries and lettering currently 
on the screen are saved in the .vp3 file. Files can be saved to the Designer SE 
memory, a connected USB stick or a connected computer.

Errors from Undefined Thread Colors in Embroideries Saved from the 
Interactive Designer Screen
When a file that does not have full thread definitions is loaded on the Interactive 
Designer screen and then saved in .vp3 format, each color will be saved with only 
the RGB value (this assumes that colors have not been changed on the Interactive 
Designer screen). If the file is later opened in the PREMIER+™ 2 Embroidery 
System, attempting to change such a thread color will give the message that it is 
undefined and it will be automatically converted to the nearest thread color in the 
Import Thread Range set in PREMIER+™ 2 Configure.
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Changing Thread Colors to Available Thread Shades
A fixed set of 64 thread shades from the Sulky Rayon 40 range is available for 
changing colors in the Designer SE, as follows:

If a color in an embroidery is changed to one of these colors, the .vp3 embroidery 
file will contain the full thread definition for that color when the embroidery is 

1005 Black 1042 Blue Ink

1240 Smoky Gray 1293 Deep Nassau Blue

1219 Gray 0572 Blue Ribbon

1327 Dk. Whisper Gray 1226 Dk. Periwinkle

1001 Bright White 1165 Lt. Sky Blue

1082 Ecru 1248 Med. Pastel Blue

1128 Dk. Ecru 1196 Blue

1266 Toast 1096 Dk. Turquoise

1173 Med. Army Green 1554 Purple Passion

1156 Lt. Army Green 1192 Fuchsia

1211 Lt. Khaki 1033 Dk. Orchid

1229 Lt. Putty 1080 Orchid

1063 Pale Yellow-Green 1111 Pastel Orchid

1061 Pale Yellow 1254 Dusty Lavender

1135 Pastel Yellow 1561 Deep Hyacinth

1023 Yellow 1194 Lt. Purple

1079 Emerald Green 1263 Red Jubilee

1278 Bright Green 1037 Lt. Red

1274 Nile Green 1317 Poppy

1100 Lt. Grass Green 1019 Peach

1331 Pale Green 1068 Pink Tint

1104 Pastel Yellow-Green 1064 Pale Peach

1332 Deep Chartreuse 1154 Coral

1177 Avocado 1034 Burgundy

1550 Desert Cactus 1058 Tawny Brown

1551 Ocean Aqua 1056 Med. Tawny Tan

1288 Aqua 0621 Sunset

1560 Marine Aqua 1021 Maple

1045 Lt. Teal 0568 Cinnamon

1204 Pastel Jade 1333 Sunflower Gold

1205 Med. Jade 1065 Orange Yellow

1206 Dark Jade 1185 Golden Yellow
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saved from the Interactive Designer screen. This will be displayed and identified 
correctly if it is loaded into a PREMIER+™ 2 Embroidery System app.

Thread Colors and the PFAFF® creative sensation pro, 
sensation, performance, vision, 4.0 and 2.0

Thread Color Representation
When PREMIER+™ 2 Embroidery System embroidery files in .vp3 format are 
displayed on the High Definition (HD) screen, the thread colors are displayed 
correctly according to the first color in the thread definition (some threads have 
multiple colors in the thread definition). However, the thread type and weight is 
not used. This means the following:

• All thread types are displayed as if they are rayon, so, for example, metallic 
effects will not be seen

• Threads are displayed with the same thread weight, which is approximately 
equivalent to 40 weight

HD Screen Display of Colors
While the HD screen can display the thread colors correctly according to their 
RGB (red, green, blue) values, some colors may still appear different than they do 
on a computer monitor. This is because of the inherent differences in the displays 
themselves. The same colors can even look different on two identical monitors if 
their brightness, contrast and color settings are different.

Thread Names
Thread names from .vp3 embroidery files are shown on the creative vision as the 
first four characters of the thread range abbreviation, the thread weight and thread 
number.

No thread range, thread weight or manufacturer's thread number is shown for 
other file types as this information is not present in other file types. The only 
exception is for .vip embroideries, which shows the thread range for each color in 
the embroidery. This applies when opening embroideries on the machine in their 
native format, rather than sending them from the PREMIER+™ 2 Embroidery 
System.

Thread Conversion
Embroideries other than .vp3 are converted to .vp3 when they are sent from the 
PREMIER+™ 2 Embroidery System. When .vip embroideries are converted, the 
equivalent thread ranges are used. For all other embroidery file formats, the 
threads are converted to the nearest matching color from the Import Thread 
Range chosen in PREMIER+™ 2 Configure.

It is also possible, however, to open embroideries directly by browsing the 
computer from some machines, and to open embroideries that have been placed 
on a USB stick. In this case, the embroideries are opened in their original format. 
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The thread colors will be displayed in the RGB colors used by the file format. The 
color changes are numbered and no thread range or thread number information is 
shown. The only exception is for .vip embroideries, which show the thread ranges 
for colors in the embroidery. To see the thread numbers in a .vip embroidery, send 
the embroidery from the PREMIER+™ 2 Embroidery System.

Saving Embroideries from the HD Screen
Embroideries are always saved in Husqvarna Viking / Pfaff .vp3 format from the HD 
screen. All embroideries and lettering currently on the screen are saved in the .vp3 
file. Files can be saved to the creative vision memory, a connected USB stick or a 
connected computer.

Errors from Undefined Thread Colors in Embroideries Saved from the HD 
Screen
When a file that does not have full thread definitions is loaded on the HD screen 
and then saved in .vp3 format, each color will be saved with only the RGB value 
(this assumes that colors have not been changed on the HD screen). If the file is 
later opened in the PREMIER+™ 2 Embroidery System, attempting to change such 
a thread color will give the message that it is undefined and it will be automatically 
converted to the nearest thread color in the Import Thread Range set in 
PREMIER+™ 2 Configure.

Changing Thread Colors to Available Thread Shades
A fixed set of 64 thread shades from the Robison-Anton Rayon 40 range is available 
for changing colors, as follows:

2296 Black 2439 Blue Ribbon

2217 Twilight 2437 Empire Blue

2731 Gull 2527 Soldier Blue

2539 Chrome 2614 Pro Lusty Blue

2297 Snow White 2300 Ice Blue

2335 Ivory 2239 Sky Blue

2298 Taupe 2533 Ozone

2478 Light Cocoa 2577 Wonder Blue

2544 Desert Cactus 2490 Plum Wine

2545 Cypress 2500 New Berry

2221 Willow 2424 Cachet

2241 Palm Leaf 2588 Mid Lilac

2316 Celery 2243 Light Pink

2557 Yellow 2286 Tulip

2264 Chinese Yellow 2287 Mauve

2462 Sunflower 2288 Iris
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If a color in an embroidery is changed to one of these colors, the .vp3 embroidery 
file will contain the full thread definition for that color when the embroidery is 
saved from the HD screen. This will be displayed and identified correctly if it is 
loaded into a PREMIER+™ 2 Embroidery System app.

Thread Colors and the Brother .Pes Format
When choosing colors from the Brother Poly Satin 50 thread range a few colors 
will appear different on the machine screen when the file is saved to a .pes format. 
The colors that are affected are shown in the table.

When a design is read back, the RGB values for the thread colors are converted to 
the nearest thread from the Import Thread Range set in PREMIER+™ 2 Configure.

2208 Dark Green 2263 Foxy Red

2579 Vibrant Green 2420 Tuxedo Red

2738 Pro Erin 2467 Orangeade

2555 Pastel Green 2253 Flesh Pink

2318 Pale Green 2413 Flesh

2547 Pebblestone 2377 Bisque

2279 Spruce 2237 Carnation

2457 Green Dust 2504 Cherrystone

2607 TH Green 2629 Pro Walnut

2515 Bluestone 2489 Wicker

2518 Indian Ocean Blue 2518 Old Dark Tex Orange

2452 Green Pearl 2289 Rust

2310 Mint Julep 2231 Toast

2313 Sprite 2331 Mustard

2617 Pro Twinkle 2409 Yellow Mist

2309 Teal 2396 Brite Yellow

86 Deep Rose Carmine (807)

620 Magenta Lilac (612) 

205 Yellow Harvest Gold (206)

208 Orange Pumpkin (126)

339 Clay Brown Reddish Brown (337)

405 Blue Electric Blue (420)

613 Violet Royal Purple (869)

607 Wistaria Violet Lilac (612)
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